24/7 Support - 800.608.6482

Miva Merchant Community Forums

  1. #1
    Join Date
    Mar 2006
    Location
    Greater Seattle
    Posts
    473

    Default Facebook image issue

    I'm experiencing a quirky thing with Facebook. Whenever I post the link to one of our Miva items it tells me the number of images on the page as normal but the list does NOT include the primary item image. It only sees those from Related Items. If there is only one Related Item it chooses that one and completes posting of the message. If there are no Related Items it will not show any images to choose from.

    My Miva install is current. I am using Image machine but have seen this behavior on items with the new approach and those still with only the Legacy Images.

    Anybody else seen this or have ideas?

    Thanks!
    Keith Oratz
    PrepareSmart, LLC - Emergency Preparedness Supplies and Professional Grade Search and Rescue Gear
    www.preparesmart.com

  2. #2
    Join Date
    Apr 2006
    Location
    Marin County, California
    Posts
    3,310

    Default Re: Facebook image issue

    Yeah, this is pretty common with the way that the main image is referenced via javascript / css when using the image machine - even if that particular product DOESN'T make use of the image machine functionality.

    I believe the way to get around this is to use the open graph tags... search for facebook open graph image tag or something like that if you don't know what that is.

    but don't quote me on that. I have to see whether my pages are showing the correct image when I try to like them in facebook.
    Mark Romero
    ~~~~~~~~

  3. #3
    Join Date
    Mar 2006
    Posts
    11,197

    Default Re: Facebook image issue

    If you are using the additional images instead of the legacy thumbnail/full size image because you have implemented the image machine, you could use the Emporium Plus Tool Kit to grab that image url and submit it as the Facebook image, defined in the head section of your page. If there is not the additional image, you could fall back and use the legacy full sized image.
    Code:
    <mvt:item name="toolkit" param="customimage|big|l.all_settings:product:id|default" />
    <mvt:if expr="g.big">
    <meta property="og:image" content="http://www.YOURDOMAIN.com/mm5/&mvta:global:big;" />
    <mvt:else>
    <mvt:if expr="l.settings:product:image">
    <meta property="og:image" content="http://www.YOURDOMAIN.com/mm5/&mvta:product:image;" />
    </mvt:if>
    </mvt:if>
    See http://www.emporiumplus.com/1AA00223.html for more explanation at #134 on how to use that function.
    Last edited by wcw; 04-29-12 at 09:31 AM.

  4. #4
    Join Date
    Mar 2006
    Location
    Greater Seattle
    Posts
    473

    Default Re: Facebook image issue

    Thanks Bill. I'm finally getting back to this and am having trouble getting it to work. After placing the modified code in the head (Header?) should I see another image available to choose in Facebook? Is it that easy? If not, how do I access the "big" image in Facebook? The test product has one additional image which I implemented in order to use the close-up functionality. As a side note, I still have a legacy image in the Thumbnail field in order to display it on Category page. Before I can update the Category Template to use the image machine I believe I have to create additional images for all the other items in the store.

    Thanks!
    Keith Oratz
    PrepareSmart, LLC - Emergency Preparedness Supplies and Professional Grade Search and Rescue Gear
    www.preparesmart.com

Posting Rules

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •